summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 15 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2a3b0f5..9c46925 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,15 +19,25 @@
# along with ivcall; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-AC_PREREQ(2.57)
-AC_INIT([ivcall], [0.2], [mzvipnyy@itaparica.org])
+AC_PREREQ(2.58)
+AC_INIT([ivcall], [0.3], [mzvipnyy (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([src/ivcall.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
-AM_MAINTAINER_MODE
+
+AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/ivcall/])
+
+if type -p stow > /dev/null && test -d /usr/local/stow ; then
+ AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
+ ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
+fi
# Checks for programs.
AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
@@ -36,16 +46,12 @@ fi
# Specify the locking directory
AC_ARG_WITH(lockdir,
- AC_HELP_STRING([--with-lockdir=LOCKDIR], [Specify a lock dir]),
+ AC_HELP_STRING([--with-lockdir=LOCKDIR], [Specify a UUCP lock dir]),
LOCK_DIR="${withval}",
LOCK_DIR="/var/lock")
AC_SUBST(LOCK_DIR)
+AC_MSG_NOTICE([*** Using $LOCK_DIR as lock directory ***])
-AC_PROG_CPP
-AC_PROG_INSTALL
-AC_PROG_LN_S
-AC_PROG_MAKE_SET
-
AC_CHECK_FUNCS([alarm memset select strdup strerror strrchr])
AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h])
@@ -100,7 +106,5 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
-AC_MSG_NOTICE([*** Using $LOCK_DIR as lock directory ***])
-
AC_CONFIG_FILES([src/Makefile Makefile man/Makefile doc/Makefile doc/README.html])
AC_OUTPUT