summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-01-07 20:34:53 +0000
committerLennart Poettering <lennart@poettering.net>2005-01-07 20:34:53 +0000
commit6e7b4e60d5cbbc34b99b6a4cb3e22d061e1843a7 (patch)
treeac8fc89d5be15ab8cbf7f88874c48132a0ae4035 /configure.ac
parent4c4420d73c00d8f50fdc54c8e68977d9e2d59742 (diff)
* add documentation
* add SVN ids * add doxygen stuff * gcc 2.95 compat * add LICENSE * complete autoconf/autotools setup * cleanup example * fix asyncns_wait() * cope with prctl() failing git-svn-id: file:///home/lennart/svn/public/libasyncns/trunk@10 cc0fb855-19ed-0310-866e-8c1d96e4abae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8bef643..4eb0200 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,15 +37,31 @@ fi
# Checks for programs.
AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
# libtool stuff
AC_PROG_LIBTOOL
# Checks for header files.
AC_HEADER_STDC
-
-AC_CHECK_FUNCS(setresuid)
-AC_CHECK_FUNCS(setreuid)
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h stdlib.h string.h sys/socket.h unistd.h sys/prctl.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_FUNC_SELECT_ARGTYPES
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS([memset select strndup setresuid setreuid])
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
@@ -75,5 +91,5 @@ fi
AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
-AC_CONFIG_FILES([Makefile libasyncns/Makefile])
+AC_CONFIG_FILES([Makefile libasyncns/Makefile doc/Makefile doc/README.html doxygen/Makefile doxygen/doxygen.conf libasyncns.pc])
AC_OUTPUT