summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-02-16 13:51:54 +0000
committerLennart Poettering <lennart@poettering.net>2007-02-16 13:51:54 +0000
commitec3ad0d5b3f261743917e870ef3371b0af314010 (patch)
tree8e3a55dba1e2d142926e28c5b377dd91102c0bf2 /configure.ac
parent5d93f3bb4cd305969a97167de32132f2c7eee3e9 (diff)
assorted build system updates
git-svn-id: file:///home/lennart/svn/public/libasyncns/trunk@28 cc0fb855-19ed-0310-866e-8c1d96e4abae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 38 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index ea13552..e1c1dac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,16 +19,15 @@
# along with libasyncns; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-AC_PREREQ(2.57)
-AC_INIT([libasyncns],[0.1],[mznflapaf (at) 0pointer (dot) de])
+AC_PREREQ(2.59)
+AC_INIT([libasyncns],[0.2],[mznflapaf (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([libasyncns/asyncns.c])
AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE([foreign -Wall])
+AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
-AC_SUBST(PA_MAJORMINOR, "$PACKAGE_VERSION")
AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/libasyncns/])
-AC_SUBST(PA_API_VERSION, 8)
+AC_SUBST(LIBASYNCNS_VERSION_INFO, [1:0:1])
if type -p stow > /dev/null && test -d /usr/local/stow ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
@@ -38,29 +37,59 @@ fi
# Checks for programs.
AC_PROG_CC
AC_PROG_CPP
+
+AC_GNU_SOURCE
+
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-
-# libtool stuff
AC_PROG_LIBTOOL
+test_gcc_flag() {
+ AC_LANG_CONFTEST([int main() {}])
+ $CC -c conftest.c $CFLAGS $@ > /dev/null 2> /dev/null
+ ret=$?
+ rm -f conftest.o
+ return $ret
+}
+
+# If using GCC specify some additional parameters
+if test "x$GCC" = "xyes" ; then
+
+ DESIRED_FLAGS="-std=c99 -Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter"
+
+ for flag in $DESIRED_FLAGS ; do
+ AC_MSG_CHECKING([whether $CC accepts $flag])
+ if test_gcc_flag $flag ; then
+ CFLAGS="$CFLAGS $flag"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+ done
+fi
+
# Checks for header files.
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h stdlib.h string.h sys/socket.h unistd.h sys/prctl.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h stdlib.h string.h sys/socket.h unistd.h sys/prctl.h netinet/in.h])
+AC_HEADER_RESOLV
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_PID_T
AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+AC_TYPE_UINT16_T
+AC_TYPE_UINT8_T
AC_HEADER_TIME
+
# Checks for library functions.
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_SELECT_ARGTYPES
AC_TYPE_SIGNAL
-AC_CHECK_FUNCS([memset select strndup setresuid setreuid])
+AC_CHECK_FUNCS([memset select strndup setresuid setreuid strerror])
AC_CHECK_LIB(nsl, gethostbyname)
AC_CHECK_LIB(socket, connect)
@@ -74,15 +103,6 @@ AC_CHECK_FUNC(res_query, ,
ACX_PTHREAD
-# If using GCC specify some additional parameters
-if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"
-
- AC_LANG_CONFTEST([int main() {}])
- $CC -c conftest.c -std=c99 -Wno-unused-parameter $CFLAGS > /dev/null 2> /dev/null && CFLAGS="$CFLAGS -std=c99 -Wno-unused-parameter"
- rm -f conftest.o
-fi
-
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
AC_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),