summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-31 23:23:51 +0100
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-31 23:23:51 +0100
commit23247f130601fc02a5368c02e513bb0e28597ef9 (patch)
tree815609532ab320629111e51d7a72c521523dcd40 /configure.ac
parent7b82b481c7d34958e5872acd760239bc58cecf55 (diff)
Remove libltdl, similarly to what has been done on PulseAudio.
Get rid of the internal copy of libltdl and instead use the system copy, requiring that to be available. It does not make sense to duplicate this further, and it's especially a bad idea to use an internal older copy of the library for distributors and final users.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 25 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 79c05b8..51dc305 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,9 +65,32 @@ done
#### libtool stuff ####
LT_PREREQ(2.2)
-LT_CONFIG_LTDL_DIR([libltdl])
LT_INIT([dlopen win32-dll disable-static])
-LTDL_INIT([convenience recursive])
+
+dnl Unfortunately, even up to libtool 2.2.6a there is no way to know
+dnl exactly which version of libltdl is present in the system, so we
+dnl just assume that it's a working version as long as we have the
+dnl library and the header files.
+dnl
+dnl As an extra safety device, check for lt_dladvise_init() which is
+dnl only implemented in libtool 2.x, and refine as we go if we have
+dnl refined requirements.
+dnl
+dnl Check the header files first since the system may have a
+dnl libltdl.so for runtime, but no headers, and we want to bail out as
+dnl soon as possible.
+dnl
+dnl We don't need any special variable for this though, since the user
+dnl can give the proper place to find libltdl through the standard
+dnl variables like LDFLAGS and CPPFLAGS.
+
+AC_CHECK_HEADER([ltdl.h],
+ [AC_CHECK_LIB([ltdl], [lt_dladvise_init], [LIBLTDL=-lltdl], [LIBLTDL=])],
+ [LIBLTDL=])
+
+AS_IF([test "x$LIBLTDL" = "x"],
+ [AC_MSG_ERROR([Unable to find libltdl.])])
+AC_SUBST([LIBLTDL])
#### Determine build environment ####
@@ -552,7 +575,6 @@ GTK_DOC_CHECK(1.9)
AC_CONFIG_FILES([
Makefile
-libltdl/Makefile
src/Makefile
libcanberra.pc
libcanberra-gtk.pc