summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Macks <dmacks@netspace.org>2009-04-19 03:44:24 +0200
committerLennart Poettering <lennart@poettering.net>2009-04-19 03:44:24 +0200
commitdddb6280678e18f658e65260f3914e22f8fa9639 (patch)
tree23ae59df9e70cbf487a82e6d621da4e4725757df /configure.ac
parent16e37eaa0855505ce9a1ba9bb8ef4ef9c8cd4e01 (diff)
build-system: don't do gconf if gtk is disabled
libcanberra.schemas is the gconf hook for canberra-gtk-module, so it shouldn't be installed if gtk is disabled in the libcanberra build ("no canberra-gtk-module" should propagate "no pointers to it"). Closes bz #20926
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 86f064c..f0abff5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -346,6 +346,7 @@ AC_ARG_ENABLE([gtk],
],
[gtk=auto])
+AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [false])
if test "x${gtk}" != xno ; then
PKG_CHECK_MODULES(GTK, [ gtk+-2.0 >= 2.13.4 gthread-2.0 ],
[
@@ -353,6 +354,7 @@ if test "x${gtk}" != xno ; then
AC_DEFINE([HAVE_GTK], 1, [Have GTK?])
AC_PATH_PROG(GCONFTOOL, gconftool-2)
+ AM_GCONF_SOURCE_2
GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-2.0`
GTK_MODULES_DIR="${libdir}/gtk-2.0/modules"
@@ -367,7 +369,6 @@ else
HAVE_GTK=0
fi
-AM_GCONF_SOURCE_2
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)