summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-09-02 19:33:16 +0200
committerLennart Poettering <lennart@poettering.net>2008-09-02 19:33:16 +0200
commit9bd62aef042c65427f60473e591e719c51121903 (patch)
treecd54fb52f6cfce0263a88ce42d92fbd61a283222 /src/Makefile.am
parent290730ffc05735874a584063a838a8a30ce2baca (diff)
add tdb based shared lookup cache
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dddfeba..a1a4a1a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,6 +66,18 @@ if USE_VERSION_SCRIPT
libcanberra_la_LDFLAGS += -Wl,-version-script=$(srcdir)/map-file
endif
+if HAVE_CACHE
+
+libcanberra_la_SOURCES += \
+ cache.c cache.h
+libcanberra_la_CFLAGS += \
+ $(TDB_CLFAGS) \
+ -DCA_MACHINE_ID=\"$(localstatedir)/lib/dbus/machine-id\"
+libcanberra_la_LIBADD += \
+ $(TDB_LIBS)
+
+endif
+
plugin_LTLIBRARIES =
if BUILTIN_DSO