summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-20 16:53:56 -0400
committerLennart Poettering <lennart@poettering.net>2008-08-21 04:23:38 +0200
commitd7d6d26e1f858841f333264a07edc512066269af (patch)
tree85659c6e24d69ad7fcc1ace2ffdfcf5f935f6e11 /src/Makefile.am
parentf1ca2213fa649a9e3635ec7638b6c5bced594787 (diff)
OSS driver take 3
This adds the necessary error checking, and fixes the s/alsa/oss/ problem in configure.ac. Signed-off-by: Lennart Poettering <lennart@poettering.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 198202b..9f1549b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -167,6 +167,34 @@ libcanberra_alsa_la_LDFLAGS = \
endif
endif
+if HAVE_OSS
+if BUILTIN_OSS
+
+libcanberra_la_SOURCES += \
+ oss.c
+
+else
+
+plugin_LTLIBRARIES += \
+ libcanberra-oss.la
+
+libcanberra_oss_la_SOURCES = \
+ oss.c
+libcanberra_oss_la_CFLAGS = \
+ -Ddriver_open=oss_driver_open \
+ -Ddriver_destroy=oss_driver_destroy \
+ -Ddriver_change_device=oss_driver_change_device \
+ -Ddriver_change_props=oss_driver_change_props \
+ -Ddriver_play=oss_driver_play \
+ -Ddriver_cancel=oss_driver_cancel \
+ -Ddriver_cache=oss_driver_cache
+libcanberra_oss_la_LIBADD = \
+ libcanberra.la
+libcanberra_oss_la_LDFLAGS = \
+ -avoid-version -module -export-dynamic
+endif
+endif
+
if HAVE_NULL
if BUILTIN_NULL