summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2011-02-09 21:11:55 +0100
committerLennart Poettering <lennart@poettering.net>2011-02-09 21:12:06 +0100
commitdfd5e05f01dd4d28bc6c5ebc3c991404723bc076 (patch)
tree71ad869db0e6c342b8eab3fcc21b4c22e1f66033 /src/Makefile.am
parentda8e6ae8248d35cc7bcacdea0c1b874458c60ed4 (diff)
boot: add utility to play boot up sound
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d1606fa..48c75ba 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -273,9 +273,30 @@ libcanberra_null_la_LDFLAGS = \
endif
endif
+bin_PROGRAMS =
+
+if HAVE_UDEV
+if HAVE_ALSA
+
+bin_PROGRAMS += \
+ canberra-boot
+
+canberra_boot_SOURCES = \
+ canberra-boot.c
+
+canberra_boot_LDADD = \
+ $(UDEV_LIBS) \
+ libcanberra.la
+
+canberra_boot_CFLAGS = \
+ $(UDEV_CFLAGS)
+
+endif
+endif
+
if HAVE_GTK_ANY
-bin_PROGRAMS = \
+bin_PROGRAMS += \
canberra-gtk-play
include_HEADERS += \