summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-07-31 14:18:41 +0000
committerLennart Poettering <lennart@poettering.net>2003-07-31 14:18:41 +0000
commite774e8ef3467e81ed502e19b1719b4ab384d0083 (patch)
tree8eb9ee6196c383347cb2be00ec389d5c177b5d17 /Makefile.am
Moved to trunk
git-svn-id: file:///home/lennart/svn/public/libdaemon/trunk@38 153bfa13-eec0-0310-be40-b0cb6a0e1b4b
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..97b9f7b
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,36 @@
+# $Id$
+#
+# This file is part of libdaemon.
+#
+# libdaemon is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libdaemon is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libdaemon; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+EXTRA_DIST=bootstrap.sh README LICENSE libdaemon.spec
+SUBDIRS=src doc examples
+
+MAINTAINERCLEANFILES = README libdaemon.spec
+noinst_DATA = README libdaemon.spec
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ ln -s doc/README README
+
+homepage:
+ test -d $$HOME/homepage/lennart
+ mkdir -p $$HOME/homepage/lennart/projects/libdaemon
+ cp *.tar.gz $$HOME/homepage/lennart/projects/libdaemon
+ cp doc/README.html doc/style.css $$HOME/homepage/lennart/projects/libdaemon
+ cp $$HOME/homepage/lennart/projects/libdaemon/README.html $$HOME/homepage/lennart/projects/libdaemon/index.html
+ cp -av doc/reference/ $$HOME/homepage/lennart/projects/libdaemon/