summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-11-19 03:19:39 +0100
committerDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-11-19 03:19:39 +0100
commit13b221963b185cebe8cb691f936b186f2fa89310 (patch)
tree7d43ad8c41592cbdecbbac4ab8c8618b9bdbf206 /configure.ac
parent8acfe83cb4c50807eec1f261f5ee2eb8fb4025b2 (diff)
Update the attributes.m4 macro file from xine-lib/lscube.
Also use the new CC_CHECK_CFLAGS_APPEND macro instead of doing the for loop manually.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a185464..3078ab4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,11 +44,7 @@ AC_USE_SYSTEM_EXTENSIONS
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
-DESIRED_FLAGS="-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter -ffast-math"
-
-for flag in $DESIRED_FLAGS ; do
- CC_CHECK_CFLAGS([$flag], [CFLAGS="$CFLAGS $flag"])
-done
+CC_CHECK_CFLAGS_APPEND([-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter -ffast-math])
# Checks for header files.
AC_HEADER_ASSERT