summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-03-26 22:23:57 +0000
committerLennart Poettering <lennart@poettering.net>2008-03-26 22:23:57 +0000
commit24fb7e886251e5e836f1a54463ba9e5bab792be7 (patch)
treefdf34d447210e817b5c87de884087a1c38eef175 /configure.ac
parent20b6e129fcd2595f0cd063c0dc84c527255cd23f (diff)
Discover presence of lynx, rather than error out if not present and --disable-lynx not given. Patch from Flameeyes
git-svn-id: file:///home/lennart/svn/public/libdaemon/trunk@134 153bfa13-eec0-0310-be40-b0cb6a0e1b4b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index cbb2c00..317a147 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,22 +91,22 @@ AC_TYPE_SIZE_T
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
- AS_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),
+ AC_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),
[case "${enableval}" in
yes) lynx=yes ;;
no) lynx=no ;;
*) AC_MSG_ERROR(bad value ${enableval} for --disable-lynx) ;;
esac],[lynx=yes])
-if test x$lynx != xno ; then
+if test x$lynx = xyes ; then
AC_CHECK_PROG(have_lynx, lynx, yes, no)
- if test x$lynx = xyes && test x$have_lynx = xno ; then
- AC_MSG_ERROR([*** Lynx enabled but couldn't find lynx ***])
+ if test x$have_lynx = xno ; then
+ AC_MSG_WARN([*** lynx not found, plain text README will not be built ***])
fi
fi
-AM_CONDITIONAL([USE_LYNX], [test "x$lynx" != xno])
+AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
AC_CONFIG_FILES([libdaemon/Makefile Makefile doc/Makefile doc/README.html doc/doxygen.conf examples/Makefile libdaemon.spec libdaemon.pc])
AC_OUTPUT