summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-01-10 18:45:49 +0000
committerLennart Poettering <lennart@poettering.net>2004-01-10 18:45:49 +0000
commit8f34edf681b6a5d80af6cde9bd0cb72197e88b33 (patch)
tree37543b52d6cb5a58ee2486d964fdb6856ea38841 /configure.ac
parentd18c69323e4672fcf022ad285aea039f335a0451 (diff)
some last minute changes
git-svn-id: file:///home/lennart/svn/public/libdaemon/trunk@49 153bfa13-eec0-0310-be40-b0cb6a0e1b4b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index a7ddaae..7cbf6d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,26 +25,28 @@ AC_CONFIG_SRCDIR([src/dfork.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
+AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/libdaemon/])
+
+if type -p stow > /dev/null && test -d /usr/local/stow ; then
+ AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
+ ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
+fi
+
# Checks for programs.
AC_PROG_CC
AC_PROG_CXX
+AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
-AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/libdaemon/])
-
# If using GCC specifiy some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
-if type -p stow > /dev/null && test -d /usr/local/stow ; then
- AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
- ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
-fi
-
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h syslog.h unistd.h])
+AC_HEADER_SYS_WAIT
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST