summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-05-23 01:22:36 +0000
committerLennart Poettering <lennart@poettering.net>2007-05-23 01:22:36 +0000
commitcfcb13954cdcaed4d9650b47ce480675f7378562 (patch)
treef2fae69473df8b466b0c54d6a7ef10c9a86416ad /configure.ac
parentfc8992236e8f1a836dc557f842fc0a12bf640b21 (diff)
allow automatic detection of lynx support. Closes PulseAudio bug #64.
git-svn-id: file:///home/lennart/svn/public/libdaemon/trunk@114 153bfa13-eec0-0310-be40-b0cb6a0e1b4b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ac122e0..80657c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,8 +34,8 @@ if type -p stow > /dev/null && test -d /usr/local/stow ; then
fi
# Checks for programs.
-AC_GNU_SOURCE
AC_PROG_CC
+AC_GNU_SOURCE
AC_PROG_CXX
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
@@ -98,15 +98,15 @@ AC_ARG_ENABLE(lynx,
*) AC_MSG_ERROR(bad value ${enableval} for --disable-lynx) ;;
esac],[lynx=yes])
-if test x$lynx = xyes ; then
+if test x$lynx != xno ; then
AC_CHECK_PROG(have_lynx, lynx, yes, no)
- if test x$have_lynx = xno ; then
- AC_MSG_ERROR([*** Sorry, you have to install lynx or use --disable-lynx ***])
+ if test x$lynx = xyes && test x$have_lynx = xno ; then
+ AC_MSG_ERROR([*** Lynx enabled but couldn't find lynx ***])
fi
fi
-AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
+AM_CONDITIONAL([USE_LYNX], [test "x$lynx" != xno])
AC_CONFIG_FILES([libdaemon/Makefile Makefile doc/Makefile doc/README.html doc/doxygen.conf examples/Makefile libdaemon.spec libdaemon.pc])
AC_OUTPUT