summaryrefslogtreecommitdiffstats
path: root/libdaemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-12-18 23:29:50 +0000
committerLennart Poettering <lennart@poettering.net>2004-12-18 23:29:50 +0000
commit91511db7500439088b8b3bb08ce6ee6f8f8e6499 (patch)
tree06e43cebbd77993fa7ce7a9ad11ccc0b7a4ff3ab /libdaemon/Makefile.am
parent46be51bbc763d02922da18b1b3d7946aba9ab4ea (diff)
rename src/ to libdaemon/
git-svn-id: file:///home/lennart/svn/public/libdaemon/trunk@71 153bfa13-eec0-0310-be40-b0cb6a0e1b4b
Diffstat (limited to 'libdaemon/Makefile.am')
-rw-r--r--libdaemon/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/libdaemon/Makefile.am b/libdaemon/Makefile.am
new file mode 100644
index 0000000..c14000c
--- /dev/null
+++ b/libdaemon/Makefile.am
@@ -0,0 +1,42 @@
+# $Id$
+#
+# This file is part of libdaemon.
+#
+# libdaemon is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libdaemon is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libdaemon; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+AM_CFLAGS=-D_GNU_SOURCE
+
+pkginclude_HEADERS = \
+ dlog.h \
+ dfork.h \
+ dsignal.h \
+ dnonblock.h \
+ dpid.h \
+ dexec.h \
+ daemon.h
+
+lib_LTLIBRARIES = libdaemon.la
+
+libdaemon_la_SOURCES = \
+ dlog.c \
+ dfork.c \
+ dsignal.c \
+ dnonblock.c \
+ dpid.c \
+ dexec.c \
+ daemon.h \
+ $(pkg_include_HEADERS)
+
+libdaemon_la_LDFLAGS = -version-info 2:1:2