summaryrefslogtreecommitdiffstats
path: root/libdaemon/Makefile.am
diff options
context:
space:
mode:
authorDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-11-19 03:21:30 +0100
committerDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-11-19 03:21:30 +0100
commitb406ecda2ce06fdb056d7ec6522893f38c3bbbdf (patch)
tree078a9900be65b9517f20084a27f93b732c6262d0 /libdaemon/Makefile.am
parent13b221963b185cebe8cb691f936b186f2fa89310 (diff)
If the linker suppors it, ensure that the library has no undefined
references. This is important to make sure that no bugs are introduced that breaks when using --as-needed.
Diffstat (limited to 'libdaemon/Makefile.am')
-rw-r--r--libdaemon/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libdaemon/Makefile.am b/libdaemon/Makefile.am
index 11a5305..220006a 100644
--- a/libdaemon/Makefile.am
+++ b/libdaemon/Makefile.am
@@ -39,4 +39,4 @@ libdaemon_la_SOURCES = \
daemon.h \
$(pkg_include_HEADERS)
-libdaemon_la_LDFLAGS = -version-info $(LIBDAEMON_VERSION_INFO)
+libdaemon_la_LDFLAGS = -version-info $(LIBDAEMON_VERSION_INFO) $(LDFLAGS_NOUNDEFINED)