summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-10-22 22:39:09 +0000
committerLennart Poettering <lennart@poettering.net>2003-10-22 22:39:09 +0000
commit6b459521ce990c3e626190f66ece300daae70dac (patch)
treec4300270e776acc711d16b5ab5e7775edea590f7 /Makefile.am
create trunk directory and move everything into it
git-svn-id: file:///home/lennart/svn/public/libnewmail/trunk@29 2d4e79f2-dfba-0310-a9f4-9628e67fcdf4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..2441372
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,41 @@
+# $Id$
+#
+# This file is part of libnewmail.
+#
+# libnewmail is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libnewmail is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libnewmail; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+EXTRA_DIST = bootstrap.sh README LICENSE
+SUBDIRS=src doc examples
+
+MAINTAINERCLEANFILES = README
+noinst_DATA = README
+
+README:
+ rm -f
+ $(MAKE) -C doc README
+ ln -s doc/README
+
+homepage:
+ test -d $$HOME/homepage/lennart
+ mkdir -p $$HOME/homepage/lennart/projects/libnewmail
+ cp *.tar.gz $$HOME/homepage/lennart/projects/libnewmail
+ cp doc/README.html doc/style.css $$HOME/homepage/lennart/projects/libnewmail
+ cp $$HOME/homepage/lennart/projects/libnewmail/README.html $$HOME/homepage/lennart/projects/libnewmail/index.html
+ cp -av doc/reference/ $$HOME/homepage/lennart/projects/libnewmail/
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck