summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-10-22 22:39:09 +0000
committerLennart Poettering <lennart@poettering.net>2003-10-22 22:39:09 +0000
commit6b459521ce990c3e626190f66ece300daae70dac (patch)
treec4300270e776acc711d16b5ab5e7775edea590f7 /configure.ac
create trunk directory and move everything into it
git-svn-id: file:///home/lennart/svn/public/libnewmail/trunk@29 2d4e79f2-dfba-0310-a9f4-9628e67fcdf4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac111
1 files changed, 111 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b145fe2
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,111 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+# $Id: configure.ac 41 2003-10-20 21:53:46Z lennart $
+
+# This file is part of libnewmail.
+#
+# libnewmail is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libnewmail is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libnewmail; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+AC_PREREQ(2.57)
+AC_INIT([libnewmail],[0.3],[mzarjznvy (at) 0pointer (dot) de])
+AC_CONFIG_SRCDIR([src/newmail.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign -Wall])
+
+# Checks for programs.
+AC_PROG_CC
+AC_LIBLTDL_INSTALLABLE
+AC_SUBST(INCLTDL)
+AC_SUBST(LIBLTDL)
+AC_LIBTOOL_DLOPEN
+AC_PROG_LIBTOOL
+
+AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/libnewmail/])
+
+# If using GCC specifiy some additional parameters
+if test "x$GCC" = "xyes" ; then
+ CFLAGS="$CFLAGS -pipe -Wall"
+fi
+
+if type -p stow > /dev/null && test -d /usr/local/stow ; then
+ AC_MSG_NOTICE([*** Found /usr/local/stow: installing to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
+ AC_PREFIX_DEFAULT([/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}])
+fi
+
+# Checks for libraries.
+AC_CHECK_LIB([oop], [oop_sys_run])
+AM_PATH_LIBGNUTLS(0.8.6,, AC_MSG_ERROR([[*** gnutls was not found ***]]))
+
+# Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([limits.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_CLOSEDIR_VOID
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_TYPE_SIGNAL
+AC_FUNC_STAT
+AC_CHECK_FUNCS([atexit gethostbyname gethostname memset realpath socket strcasecmp strchr strcspn strerror strpbrk strrchr strspn])
+
+# DOXYGEN documentation generation
+AC_ARG_ENABLE(doxygen,
+ AC_HELP_STRING([--disable-doxygen], [Turn off doxygen usage for documentation generation]),
+[case "${enableval}" in
+ yes) doxygen=yes ;;
+ no) doxygen=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-doxygen) ;;
+esac],[doxygen=yes])
+
+if test x$doxygen = xyes ; then
+ AC_CHECK_PROG(have_doxygen, doxygen, yes, no)
+
+ if test x$have_doxygen = xno ; then
+ AC_MSG_ERROR([*** Sorry, you have to install doxygen or use --disable-doxygen ***])
+ fi
+fi
+
+AM_CONDITIONAL([USE_DOXYGEN], [test "x$doxygen" = xyes])
+
+# LYNX documentation generation
+AC_ARG_ENABLE(lynx,
+ AC_HELP_STRING([--disable-lynx], [Turn off lynx usage for documentation generation]),
+[case "${enableval}" in
+ yes) lynx=yes ;;
+ no) lynx=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-lynx) ;;
+esac],[lynx=yes])
+
+if test x$lynx = xyes ; then
+ AC_CHECK_PROG(have_lynx, lynx, yes, no)
+
+ if test x$have_lynx = xno ; then
+ AC_MSG_ERROR([*** Sorry, you have to install lynx or use --disable-lynx ***])
+ fi
+fi
+
+AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
+
+AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile doc/README.html doc/doxygen.conf examples/Makefile])
+AC_OUTPUT