summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-10-22 22:39:09 +0000
committerLennart Poettering <lennart@poettering.net>2003-10-22 22:39:09 +0000
commit6b459521ce990c3e626190f66ece300daae70dac (patch)
treec4300270e776acc711d16b5ab5e7775edea590f7 /doc/Makefile.am
create trunk directory and move everything into it
git-svn-id: file:///home/lennart/svn/public/libnewmail/trunk@29 2d4e79f2-dfba-0310-a9f4-9628e67fcdf4
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..79f3826
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,52 @@
+# $Id$
+
+# This file is part of libnewmail.
+#
+# libnewmail is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libnewmail is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libnewmail; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+noinst_DATA = README.html README reference
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in reference
+
+MAINTAINERCLEANFILES = README README.html
+CLEANFILES =
+
+if USE_DOXYGEN
+reference: doxygen.conf
+ doxygen doxygen.conf
+ touch reference
+
+doxygen:
+ touch doxygen.conf
+ $(MAKE) reference
+
+maintainer-clean-local:
+ rm -rf reference
+endif
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' | sed 's,file://localhost/.*/doc/reference/,reference/,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html
+ tidy -e < README.html
+
+if USE_DOXYGEN
+.PHONY: doxygen tidy
+else
+.PHONY: tidy
+endif