summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 0 insertions, 26 deletions
diff --git a/debian/rules b/debian/rules
index de1b5e8..ed2d7e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,10 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -26,7 +19,6 @@ endif
config.status: configure
dh_testdir
- # Add here commands to configure the package.
CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
@@ -34,11 +26,7 @@ build: build-stamp
build-stamp: config.status
dh_testdir
-
- # Add here commands to compile the package.
$(MAKE)
- #docbook-to-man debian/libapache2-mod-dnssd.sgml > libapache2-mod-dnssd.1
-
touch build-stamp
clean:
@@ -81,7 +69,6 @@ install: build
# Build architecture-independent files here.
binary-indep: build install
-# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
@@ -90,24 +77,11 @@ binary-arch: build install
dh_installchangelogs
dh_installdocs
dh_installexamples
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
-# dh_perl
-# dh_python
-# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol