summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-03-24 21:15:21 +0000
committerLennart Poettering <lennart@poettering.net>2004-03-24 21:15:21 +0000
commitc174f20109543c0a0bc999369784a8ee52f7141c (patch)
treed8a892a1264831e9829f363c03bf3ae4bf7e5223 /Makefile.am
parent85b5c5365026f6a49d441e11810e8e3fe1d57ea8 (diff)
initial commit
git-svn-id: file:///home/lennart/svn/public/mod_mime_xattr/trunk@3 f01872de-66d6-0310-9185-fc3b30f50adc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..d45b20d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+# $Id$
+
+# Copyright 2004 Lennart Poettering
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you
+# may not use this file except in compliance with the License. You
+# may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# permissions and limitations under the License.
+
+EXTRA_DIST=bootstrap.sh README LICENSE NOTICE
+SUBDIRS=src doc
+
+MAINTAINERCLEANFILES = README
+noinst_DATA = README NOTICE LICENSE
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/mod_mime_xattr
+ cp *.tar.gz $$HOME/homepage/private/projects/mod_mime_xattr
+ cp doc/README.html doc/style.css $$HOME/homepage/private/projects/mod_mime_xattr
+ cp $$HOME/homepage/private/projects/mod_mime_xattr/README.html $$HOME/homepage/private/projects/mod_mime_xattr/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck