summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2011-09-19 10:31:20 +0100
committerLennart Poettering <lennart@poettering.net>2011-09-19 23:58:38 +0200
commit90949bf1b46e69b040b303b16b8799b232335501 (patch)
tree82fac0ddf30c4e4793ca1bebc62d519611caf229 /configure.ac
parent455be6e35fe1ee18d63777e1383e7f9ade0f43a3 (diff)
Port from CC_CHECK_CFLAGS_APPEND to AX_APPEND_COMPILE_FLAGS
AX_APPEND_COMPILE_FLAGS seems to be better maintained by the autoconf archive, and is what's used in PulseAudio. Everybody loves what's used in PulseAudio.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a739909..fcb1397 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@
# You should have received a copy of the GNU Lesser General Public
# License along with mutrace. If not, see <http://www.gnu.org/licenses/>.
-AC_PREREQ([2.61])
+AC_PREREQ([2.68])
AC_INIT([mutrace], [0.2], [mzzhgenpr (at) 0pointer (dot) net])
AC_CONFIG_SRCDIR([mutrace.c])
@@ -53,7 +53,8 @@ AC_USE_SYSTEM_EXTENSIONS
AC_PROG_CXX
# GCC flags
-CC_CHECK_CFLAGS_APPEND([-Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wwrite-strings -Wno-unused-parameter -Wno-strict-aliasing -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option -fno-omit-frame-pointer])
+
+AX_APPEND_COMPILE_FLAGS([-Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wwrite-strings -Wno-unused-parameter -Wno-strict-aliasing -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option -fno-omit-frame-pointer])
#### libtool stuff ####