summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-02-08 16:42:22 +0000
committerLennart Poettering <lennart@poettering.net>2007-02-08 16:42:22 +0000
commit00028b6b41d90462e4e156813778155675e9628c (patch)
treeb795b1d9cc13da0e8e865d34755d19a3ea28dd5f /configure.ac
parent650391f33529d12a0e7616ea0ba19a226128f042 (diff)
FreeBSD portability (Patch from Bruce M Simpson)
git-svn-id: file:///home/lennart/svn/public/nss-mdns/trunk@114 0ee8848e-81ea-0310-a63a-f631d1a40d77
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0cd6c3a..8592c2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,13 @@ AC_FUNC_MALLOC
AC_FUNC_SELECT_ARGTYPES
AC_CHECK_FUNCS([gethostbyaddr gethostbyname gettimeofday inet_ntoa memset select socket strcspn strdup strerror strncasecmp strcasecmp strspn])
+# FreeBSD has a slightly different NSS interface
+case ${host} in
+ *-freebsd*) freebsd="yes" ;;
+esac
+
+AM_CONDITIONAL([FREEBSD_NSS], [test "x$freebsd" = "xyes"])
+
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"