summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-12-05 19:20:08 +0000
committerLennart Poettering <lennart@poettering.net>2004-12-05 19:20:08 +0000
commit9cc3df6a1958c18bee866a6af19661623d6cd71e (patch)
treef63ec3054bd13a27093c8d89dd6d232e84f4fa2b /src/Makefile.am
parent5a12f4f892685adcbbeecbdc406a297152d0dad1 (diff)
port to autotools
git-svn-id: file:///home/lennart/svn/public/nss-mdns/trunk@54 0ee8848e-81ea-0310-a63a-f631d1a40d77
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..dc2513c
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,45 @@
+# $Id$
+#
+# This file is part of nss-mdns.
+#
+# nss-mdns is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# nss-mdns is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with nss-mdns; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+rootlibdir=/
+
+AM_CFLAGS=-D_GNU_SOURCE
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+noinst_PROGRAMS = nss-test mdns-test
+
+rootlib_LTLIBRARIES = libnss_mdns.la libnss_mdns4.la libnss_mdns6.la
+
+mdns_test_SOURCES = query.c dns.c util.c mdns-test.c
+
+nss_test_SOURCES = nss-test.c
+
+libnss_mdns_la_SOURCES = query.c dns.c util.c nss.c
+libnss_mdns_la_CFLAGS=$(AM_CFLAGS)
+libnss_mdns_la_LDFLAGS=-avoid-version -module -export-dynamic -shrext .so.2
+
+libnss_mdns4_la_SOURCES=$(libnss_mdns_la_SOURCES)
+libnss_mdns4_la_CFLAGS=$(libnss_mdns_la_CFLAGS) -DNSS_IPV4_ONLY=1
+libnss_mdns4_la_LDFLAGS=$(libnss_mdns_la_LDFLAGS)
+
+libnss_mdns6_la_SOURCES=$(libnss_mdns_la_SOURCES)
+libnss_mdns6_la_CFLAGS=$(libnss_mdns_la_CFLAGS) -DNSS_IPV6_ONLY=1
+libnss_mdns6_la_LDFLAGS=$(libnss_mdns_la_LDFLAGS)