summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-05 23:51:50 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-05 23:51:50 +0000
commite1792064898bbce2c4d7574ada82a06f5e19d47f (patch)
treec78959aca285aaa06427edc2398bd16376949f13 /src/Makefile.am
parent6dc69c9a94e128f6703ddfcc38c253f0c8cc9d7b (diff)
* require automake 1.9
* bump version number * fix a lot of problems detected after compilation with excessive warnings * merge patch from Sean Meiners, adding search list support * update for newer avahi git-svn-id: file:///home/lennart/svn/public/nss-mdns/trunk@82 0ee8848e-81ea-0310-a63a-f631d1a40d77
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ac24af2..6e537cf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,11 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
-AM_CFLAGS=-D_GNU_SOURCE -DMDNS_ALLOW_FILE=\"$(sysconfdir)/mdns.allow\"
+AM_CFLAGS = \
+ -DMDNS_ALLOW_FILE=\"$(sysconfdir)/mdns.allow\" \
+ -DRESOLV_CONF_FILE=\"$(sysconfdir)/resolv.conf\" \
+ -DAVAHI_SOCKET=\"$(localstatedir)/run/avahi-daemon/socket\"
+
#-DNDEBUG=1
# This cool debug trap works on i386/gcc only