summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2011-05-09 14:57:15 +0200
committerLennart Poettering <lennart@poettering.net>2011-05-09 14:57:15 +0200
commit8041b5bada31db152de80e45b3047ed32cef6880 (patch)
tree8feffebefe28f10bdf963f396031caf2627328be /Makefile.am
parent15ef6d41d685b60f8e41ff298534bcc5ddcfa73c (diff)
return any locally configured IP address if they exist
Fall back to 127.0.0.2/::1 only if there is no proper IP address configured on any interface.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b1dcab..7f2f3a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,8 @@ lib_LTLIBRARIES = libnss_myhostname.la
EXTRA_DIST=bootstrap.sh README LICENSE
SUBDIRS=doc
+AM_CPPFLAGS = -include $(top_builddir)/config.h
+
MAINTAINERCLEANFILES=README
noinst_DATA = README
@@ -39,8 +41,16 @@ homepage: all dist
.PHONY: homepage
-libnss_myhostname_la_SOURCES = nss-myhostname.c
-libnss_myhostname_la_LDFLAGS = -avoid-version -module -export-dynamic -shrext .so.2
+libnss_myhostname_la_SOURCES = \
+ nss-myhostname.c \
+ netlink.c \
+ netlink.h
+
+libnss_myhostname_la_LDFLAGS = \
+ -avoid-version \
+ -module \
+ -export-dynamic \
+ -shrext .so.2
install-exec-hook:
rm -f $(DESTDIR)$(libdir)/libnss_myhostname.la