summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f2f3a3..f82b8d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,8 +43,13 @@ homepage: all dist
libnss_myhostname_la_SOURCES = \
nss-myhostname.c \
- netlink.c \
- netlink.h
+ ifconf.h
+
+if LEGACY
+libnss_myhostname_la_SOURCES += legacy.c
+else
+libnss_myhostname_la_SOURCES += netlink.c
+endif
libnss_myhostname_la_LDFLAGS = \
-avoid-version \