summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38cd58f..30ebc44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,13 @@ AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/nss-myhostname/])
ac_default_prefix="/"
+AC_CANONICAL_HOST
+case "$host_os" in
+ linux*) legacy=false ;;
+ *) legacy=true ;;
+esac
+AM_CONDITIONAL([LEGACY], [test x$legacy = xtrue])
+
# Checks for programs.
AC_PROG_CC
AC_PROG_CC_C99