summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..ca8d704
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,33 @@
+# $Id$
+#
+# This file is part of padevchooser.
+#
+# padevchooser is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# padevchooser is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with padevchooser; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+desktopdir = $(datadir)/applications
+
+bin_PROGRAMS=padevchooser
+
+dist_pkgdata_DATA=padevchooser.glade
+dist_desktop_DATA=padevchooser.desktop
+
+padevchooser_SOURCES=padevchooser.c x11prop.c eggtrayicon.c
+
+padevchooser_LDADD=$(AM_LDADD) $(GUILIBS_LIBS) $(PULSE_LIBS)
+padevchooser_CFLAGS=$(AM_CFLAGS) $(GUILIBS_CFLAGS) $(PULSE_CFLAGS)
+padevchooser_CFLAGS+=-DGLADE_FILE=\"$(pkgdatadir)/padevchooser.glade\"
+padevchooser_CFLAGS+=-DEGG_COMPILATION
+