summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-07-27 18:14:19 +0000
committerLennart Poettering <lennart@poettering.net>2006-07-27 18:14:19 +0000
commitc2ec65fc81cc51573f3fb9deb02fa2830a359604 (patch)
tree49e831a8851cc24d19e0078f1f2e7c5af8a29a10 /Makefile.am
parentbd57a254d64dfd1cecb36d54e5417c5972ec1841 (diff)
initial commit
git-svn-id: file:///home/lennart/svn/public/paprefs/trunk@3 54a58c19-9419-0410-9bbb-d8fa3e5d54ff
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..92b22c3
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,39 @@
+# $Id$
+#
+# This file is part of paprefs.
+#
+# paprefs is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# paprefs is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with paprefs; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = bootstrap.sh README LICENSE
+SUBDIRS=src
+# doc
+
+MAINTAINERCLEANFILES=README
+noinst_DATA = README
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/paprefs
+ cp paprefs-@PACKAGE_VERSION@.tar.gz $$HOME/homepage/private/projects/paprefs
+ cp doc/README.html doc/screenshot.png doc/style.css $$HOME/homepage/private/projects/paprefs
+ ln -sf README.html $$HOME/homepage/private/projects/paprefs/index.html
+
+.PHONY: homepage