summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-08-05 20:22:09 +0200
committerLennart Poettering <lennart@poettering.net>2008-08-05 20:22:09 +0200
commited0914737e8bda2c1ccb0509f1a93633f21ce7a3 (patch)
tree0f51030e63755c15b4ea33938b00ba5daa873a0c /Makefile.am
parent6a1dcb24d89b6cf7b74f5604bb474af54abfb8c5 (diff)
generate changelogs from git history
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e17dcb..05ecb60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,8 +53,8 @@ fedora-snapshot: dist
ACLOCAL_AMFLAGS = -I m4
dist-hook:
- if test -d .svn ; then \
- svn update ; \
+ if test -d .git ; then \
+ git pull ; \
chmod u+w ${distdir}/ChangeLog || true ; \
- svn2cl -o ${distdir}/ChangeLog ; \
+ git-changelog.perl > ${distdir}/ChangeLog ; \
fi