summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-04-21 14:51:33 +0000
committerLennart Poettering <lennart@poettering.net>2006-04-21 14:51:33 +0000
commit296f986a9e77b2983b6dde63cbab04d4351d1303 (patch)
tree37c23e97442cb5e22bd9ba417b87c9b33342b760 /Makefile.am
parente7e438b5459d46d2d8f8e604c566fdbf8f105803 (diff)
initial commit
git-svn-id: file:///home/lennart/svn/public/pavucontrol/trunk@3 c17c95f2-f111-0410-90bf-f30a9569010c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5bbd86e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,41 @@
+# $Id$
+#
+# This file is part of pavucontrol.
+#
+# pavucontrol is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# pavucontrol is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with pavucontrol; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = bootstrap.sh# README LICENSE
+SUBDIRS=src # doc
+
+#MAINTAINERCLEANFILES=README
+#noinst_DATA = README
+
+#README:
+# rm -f README
+# $(MAKE) -C doc README
+# cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/pavucontrol
+ cp pavucontrol-@PACKAGE_VERSION@.tar.gz $$HOME/homepage/private/projects/pavucontrol
+ cp doc/README.html doc/screenshot.png doc/style.css $$HOME/homepage/private/projects/pavucontrol
+ cp $$HOME/homepage/private/projects/pavucontrol/README.html $$HOME/homepage/private/projects/pavucontrol/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck