summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-08-05 20:16:26 +0200
committerLennart Poettering <lennart@poettering.net>2008-08-05 20:16:26 +0200
commit59135fd54eba67a2c7148b74e964980878ae32fc (patch)
tree01d8241f25f56f1339f09ce0b8b437afeb11213e /Makefile.am
parent1a75fb1ddde12a1b989771b3524449b25f903ed9 (diff)
generate changelog from git history
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d5900a6..2b84337 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,8 +39,8 @@ fedora-snapshot: dist
.PHONY: homepage
dist-hook:
- if test -d .svn ; then \
- svn update ; \
+ if test -d .git ; then \
+ git pull ; \
chmod u+w ${distdir}/ChangeLog || true ; \
- svn2cl -o ${distdir}/ChangeLog ; \
+ git-changelog.perl > ${distdir}/ChangeLog ; \
fi