summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2011-01-11 11:26:48 +0000
committerColin Guthrie <cguthrie@mandriva.org>2011-01-11 11:26:48 +0000
commita37e0963efbdd9ef22561f9c1ab386ee2c09280d (patch)
treecc7f7d6f9e6ca9471e6d215752c9e4647672fb2b /configure.ac
parent0fae3ad2f8bc05efeff649951427e97e36b6e84f (diff)
build-sys: Make --disable-dbus actually work.
Previously this argument passed to configure only worked if --disable-hal and --disable-bluez was also passed which wasn't immediately obvious to the untrained compiler. This change simply makes --disable-dbus disable the other two as well and errors out of specific, incompatible --enable/--disable flags are provided. The summary table is also adjusted and intended to try and show the dependency relationship a little.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac71
1 files changed, 41 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index 2f80a42f..0cffdc12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1188,28 +1188,6 @@ AC_SUBST(UDEV_LIBS)
AC_SUBST(HAVE_UDEV)
AM_CONDITIONAL([HAVE_UDEV], [test "x$HAVE_UDEV" = x1])
-#### HAL compat support (optional) ####
-
-AC_ARG_ENABLE([hal-compat],
- AS_HELP_STRING([--disable-hal-compat],[Disable optional HAL->udev transition compatibility support]),
- [
- case "${enableval}" in
- yes) halcompat=yes ;;
- no) halcompat=no ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --disable-hal-compat) ;;
- esac
- ],
- [halcompat=auto])
-if test "x${halcompat}" != xno -a "x$HAVE_HAL" = "x0" -a "x$HAVE_UDEV" = "x1" ; then
- HAVE_HAL_COMPAT=1
- AC_DEFINE([HAVE_HAL_COMPAT], 1, [Have HAL compatibility.])
-else
- HAVE_HAL_COMPAT=0
-fi
-
-AC_SUBST(HAVE_HAL_COMPAT)
-AM_CONDITIONAL([HAVE_HAL_COMPAT], [test "x$HAVE_HAL_COMPAT" = x1])
-
#### BlueZ support (optional) ####
AC_ARG_ENABLE([bluez],
@@ -1253,11 +1231,7 @@ AC_ARG_ENABLE([dbus],
],
[dbus=auto])
-if test "x$HAVE_HAL" = x1 ; then
- dbus=yes
-fi
-
-if test "x${dbus}" != xno || test "x${bluez}" != xno || test "x${hal}" != xno ; then
+if test "x${dbus}" != xno ; then
PKG_CHECK_MODULES(DBUS, [ dbus-1 >= 1.0.0 ],
[
@@ -1284,6 +1258,43 @@ AC_SUBST(DBUS_LIBS)
AC_SUBST(HAVE_DBUS)
AM_CONDITIONAL([HAVE_DBUS], [test "x$HAVE_DBUS" = x1])
+
+# udev and HAL depend on DBUS: So double check if they were explicitly enabled.
+if test "x$HAVE_DBUS" != "x1" ; then
+ HAVE_HAL=0
+ if test "x${hal}" = xyes ; then
+ AC_MSG_ERROR([*** D-Bus support is required by HAL])
+ fi
+
+ HAVE_BLUEZ=0
+ if test "x${bluez}" = xyes ; then
+ AC_MSG_ERROR([*** D-Bus support is required by BLUEZ])
+ fi
+fi
+
+
+#### HAL compat support (optional) ####
+
+AC_ARG_ENABLE([hal-compat],
+ AS_HELP_STRING([--disable-hal-compat],[Disable optional HAL->udev transition compatibility support]),
+ [
+ case "${enableval}" in
+ yes) halcompat=yes ;;
+ no) halcompat=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-hal-compat) ;;
+ esac
+ ],
+ [halcompat=auto])
+if test "x${halcompat}" != xno -a "x$HAVE_HAL" = "x0" -a "x$HAVE_UDEV" = "x1" ; then
+ HAVE_HAL_COMPAT=1
+ AC_DEFINE([HAVE_HAL_COMPAT], 1, [Have HAL compatibility.])
+else
+ HAVE_HAL_COMPAT=0
+fi
+
+AC_SUBST(HAVE_HAL_COMPAT)
+AM_CONDITIONAL([HAVE_HAL_COMPAT], [test "x$HAVE_HAL_COMPAT" = x1])
+
### IPv6 connection support (optional) ###
AC_ARG_ENABLE([ipv6],
@@ -1669,10 +1680,10 @@ echo "
Enable Async DNS: ${ENABLE_LIBASYNCNS}
Enable LIRC: ${ENABLE_LIRC}
Enable DBUS: ${ENABLE_DBUS}
- Enable HAL: ${ENABLE_HAL}
+ Enable HAL: ${ENABLE_HAL}
+ Enable BlueZ: ${ENABLE_BLUEZ}
Enable udev: ${ENABLE_UDEV}
- Enable HAL->udev compat: ${ENABLE_HAL_COMPAT}
- Enable BlueZ: ${ENABLE_BLUEZ}
+ Enable HAL->udev compat: ${ENABLE_HAL_COMPAT}
Enable TCP Wrappers: ${ENABLE_TCPWRAP}
Enable libsamplerate: ${ENABLE_LIBSAMPLERATE}
Enable IPv6: ${ENABLE_IPV6}