summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-07-10 16:49:07 +0200
committerLennart Poettering <lennart@poettering.net>2010-07-10 16:49:07 +0200
commitf784a4a0ff09854958c34126615b1584c1ecbd05 (patch)
tree32e63da1a0fd75fa5c347f7a64df29729bdbefe1 /Makefile.am
parent72922a586a398b2f70d69ff59bfb1a379f51b670 (diff)
systemd: send systemd style status messages
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a271a98..7f5e8f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,7 +53,8 @@ systemdsystemunit_DATA = \
endif
rtkit_daemon_SOURCES = \
- rtkit-daemon.c rtkit.h
+ rtkit-daemon.c rtkit.h \
+ sd-daemon.c sd-daemon.h
rtkit_daemon_LDADD = \
$(DBUS_LIBS)
rtkit_daemon_CFLAGS = \
@@ -86,3 +87,7 @@ EXTRA_DIST += \
DISTCHECK_CONFIGURE_FLAGS = \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
+
+update-systemd:
+ curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.c > sd-daemon.c
+ curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.h > sd-daemon.h