summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-12-04 22:40:43 +0000
committerLennart Poettering <lennart@poettering.net>2003-12-04 22:40:43 +0000
commit905060b43a294dd73cbcf19eb86b66240d6d0140 (patch)
tree6bd591c547cc4a78ac15962a16d09391679bf9e9 /configure.ac
parentf19907aec71491fa517cf01f36600277e7a1ad3c (diff)
May further patches from dbindner
git-svn-id: file:///home/lennart/svn/public/seppl/trunk@19 91a2fd9b-5dcb-0310-a70a-d71e310228e6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 16307c1..58026cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,7 @@ if test "x$IPTABLES" = x ; then
AC_MSG_ERROR([*** Please install iptables ***])
fi
IPTABLES_VERSION=$("$IPTABLES" -V | cut -d' ' -f2 | sed 's/^v//')
-AC_DEFINE(IPTABLES_VERSION, [$IPTABLES_VERSION], "iptables release number")
+AC_DEFINE_UNQUOTED(IPTABLES_VERSION, ["$IPTABLES_VERSION"], "iptables release number")
AC_MSG_RESULT([$IPTABLES_VERSION])
# Init script location
@@ -98,6 +98,16 @@ AC_ARG_WITH(kernel,
AC_SUBST(KERNELDIR)
AC_MSG_RESULT([$KERNELDIR])
+AC_MSG_CHECKING([kernel configuration file])
+if ! test -r "$KERNELDIR/.config" ; then
+ cat << EOF
+You need to configure your kernel sources before building SEPPL.
+Try "make menuconfig" or "make xconfig" in the kernel source directory.
+EOF
+ exit 1
+fi
+AC_MSG_RESULT([found])
+
# Check for crypto.h
AC_MSG_CHECKING(for crypto.h)
if ! test -r $KERNELDIR/include/linux/crypto.h; then