summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 807434f..4cfa711 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,4 +18,25 @@
# This Makefile is NOT created by automake!
-SUBDIRS=kernel libs utils conf
+EXTRA_DIST = bootstrap.sh README LICENSE
+SUBDIRS=kernel libs utils conf doc
+
+MAINTAINERCLEANFILES = README
+noinst_DATA = README
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ ln -sf doc/README README
+
+homepage: dist
+ test -d $$HOME/homepage/lennart
+ mkdir -p $$HOME/homepage/lennart/projects/seppl
+ cp *.tar.gz $$HOME/homepage/lennart/projects/seppl
+ cp doc/README.html doc/style.css $$HOME/homepage/lennart/projects/seppl
+ cp $$HOME/homepage/lennart/projects/seppl/README.html $$HOME/homepage/lennart/projects/seppl/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck