summaryrefslogtreecommitdiffstats
path: root/conf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'conf/Makefile.am')
-rw-r--r--conf/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/conf/Makefile.am b/conf/Makefile.am
new file mode 100644
index 0000000..98667e2
--- /dev/null
+++ b/conf/Makefile.am
@@ -0,0 +1,31 @@
+# $Id: Makefile.am 40 2003-10-27 18:32:45Z lennart $
+#
+# This file is part of seppl.
+#
+# seppl is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# seppl is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with seppl; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+noinst_DATA = seppl.init
+EXTRA_DIST = seppl.init.in
+CLEANFILES = seppl.init
+
+seppl.init: seppl.init.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod 755 $@
+
+install-data-local: seppl.init
+ $(INSTALL) -b -D -m755 seppl.init ${DESTDIR}/${sysconfdir}/init.d/seppl
+
+uninstall-local:
+ rm -f ${DESTDIR}/${sysconfdir}/init.d/seppl