summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 19 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index fd952e6..fac7a1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,34 +19,36 @@
# along with seppl; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-AC_PREREQ(2.57)
-AC_INIT([seppl], [0.3], [mzfrccy (at) 0pointer (dot) de])
+AC_PREREQ(2.59)
+AC_INIT([seppl],[0.4],[mzfrccy (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([kernel/seppl.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
-
-# Checks for programs.
-AC_PROG_CXX
-AC_PROG_CC
AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/seppl/])
-# If using GCC specifiy some additional parameters
-if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -pipe -Wall"
-fi
-
if type -p stow > /dev/null && test -d /usr/local/stow ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
fi
+# Checks for programs.
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
+
+# If using GCC specifiy some additional parameters
+if test "x$GCC" = "xyes" ; then
+ CFLAGS="$CFLAGS -pipe -Wall"
+fi
+
AC_CHECK_FUNCS([memset])
+AC_CHECK_HEADERS([fcntl.h])
+AC_FUNC_MALLOC
+AC_TYPE_OFF_T
AC_C_CONST
# iptables version
@@ -60,7 +62,7 @@ AC_DEFINE_UNQUOTED(IPTABLES_VERSION, ["$IPTABLES_VERSION"], "iptables release nu
AC_MSG_RESULT([$IPTABLES_VERSION])
# Init script location
-AC_ARG_WITH(initdir, AC_HELP_STRING([--with-initdir=DIR], [Install init script in DIR (system dependent default)]))
+AC_ARG_WITH(initdir, AS_HELP_STRING(--with-initdir=DIR,Install init script in DIR (system dependent default)))
test "x$with_initdir" = xyes -o "x$with_initdir" = xno && with_initdir=
@@ -122,7 +124,7 @@ AC_MSG_RESULT([found])
# Check for directory for kernel modules...
AC_MSG_CHECKING(for directory for kernel modules)
AC_ARG_WITH(moddir,
- AC_HELP_STRING([--with-moddir=dir], [Give the directory to install kernel modules to]),
+ AS_HELP_STRING(--with-moddir=dir,Give the directory to install kernel modules to),
KERNELMODDIR="$withval",
if test -d "/lib/modules/`uname -r`/" -o -L "/lib/modules/`uname -r`/"; then
KERNELMODDIR="/lib/modules/`uname -r`/"
@@ -149,7 +151,7 @@ AM_PATH_PYTHON([2.1])
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
- AC_HELP_STRING([--disable-lynx], [Turn off lynx usage for documentation generation]),
+ AS_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),
[case "${enableval}" in
yes) lynx=yes ;;
no) lynx=no ;;
@@ -168,7 +170,7 @@ AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
# XMLTOMAN manpage generation
AC_ARG_ENABLE(xmltoman,
- AC_HELP_STRING([--disable-xmltoman], [Disable rebuilding of man pages with xmltoman]),
+ AS_HELP_STRING(--disable-xmltoman,Disable rebuilding of man pages with xmltoman),
[case "${enableval}" in
yes) xmltoman=yes ;;
no) xmltoman=no ;;