summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 38 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 090cf67..aeceb3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
AC_PREREQ(2.57)
-AC_INIT([seppl], [0.2], [mzfrccy (at) 0pointer (dot) de])
+AC_INIT([seppl], [0.3], [mzfrccy (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([kernel/seppl.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
@@ -39,8 +39,10 @@ if test "x$GCC" = "xyes" ; then
fi
if type -p stow > /dev/null && test -d /usr/local/stow ; then
- AC_MSG_NOTICE([*** Found /usr/local/stow: installing to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
- AC_PREFIX_DEFAULT([/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}])
+ AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
+ ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
+else
+ ac_default_prefix="/usr/local"
fi
AC_PROG_INSTALL
@@ -49,6 +51,38 @@ AC_PROG_MAKE_SET
AC_CHECK_FUNCS([memset])
AC_C_CONST
+# iptables version
+AC_PATH_PROG([IPTABLES], [iptables], [iptables], [$PATH:/usr/local/sbin:/usr/sbin:/sbin])
+AC_MSG_CHECKING([iptables release])
+if test "x$IPTABLES" = x ; then
+ AC_MSG_ERROR([*** Please install iptables ***])
+fi
+IPTABLES_VERSION=$("$IPTABLES" -V | cut -d' ' -f2 | sed 's/^v//')
+AC_DEFINE(IPTABLES_VERSION, [$IPTABLES_VERSION], "iptables release number")
+AC_MSG_RESULT([$IPTABLES_VERSION])
+
+# Init script location
+AC_ARG_WITH(initdir, AC_HELP_STRING([--with-initdir=DIR], [Install init script in DIR (system dependent default)]))
+
+test "x$with_initdir" = xyes -o "x$with_initdir" = xno && with_initdir=
+
+if test "x$with_initdir" = x ; then
+ if test -d /etc/init.d ; then
+ SYSINITDIR=/etc/init.d
+ else
+ if test -d /etc/rc.d/init.d ; then
+ SYSINITDIR=/etc/rc.d/init.d
+ else
+ AC_MSG_ERROR([missing --with-initdir=DIR])
+ fi
+ fi
+else
+ SYSINITDIR="$with_initdir"
+fi
+
+AC_MSG_NOTICE([Init sript will be installed in $SYSINITDIR])
+AC_SUBST(SYSINITDIR)
+
# Check for directory with kernel source...
AC_MSG_CHECKING(for directory with kernel source)
AC_ARG_WITH(kernel,
@@ -144,5 +178,5 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
-AC_CONFIG_FILES([kernel/Makefile libs/Makefile Makefile utils/Makefile conf/Makefile doc/Makefile doc/README.html])
+AC_CONFIG_FILES([kernel/Makefile libs/Makefile Makefile utils-python/Makefile conf/Makefile doc/Makefile doc/README.html])
AC_OUTPUT