summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Droege <slomo@ubuntu.com>2005-10-06 14:41:58 +0000
committerSebastian Droege <slomo@ubuntu.com>2005-10-06 14:41:58 +0000
commit37199f0fd28d5f036d99d4755544ffa90436b600 (patch)
treee9ec1a068ad654801cba3b16172c243053222c74 /configure.ac
parentaeb1d09124bd57ecf78e138c4466d682827eb354 (diff)
* added localization to sda
git-svn-id: file:///home/lennart/svn/public/service-discovery-applet/trunk@45 3be567f1-68ff-0310-b24a-ad7cc433fd2f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index df2fa4a..c914f22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,8 @@ AC_CONFIG_SRCDIR([src/service-discovery-applet.in])
AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
AC_CONFIG_MACRO_DIR([common])
+AC_PROG_INTLTOOL([0.21])
+
AC_SUBST(VERSION)
AM_MAINTAINER_MODE
@@ -42,6 +44,19 @@ dnl ========================================================
AM_GCONF_SOURCE_2
dnl ========================================================
+dnl This is for gettext support
+dnl ========================================================
+GETTEXT_PACKAGE=service-discovery-applet
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package])
+AC_SUBST(GETTEXT_PACKAGE)
+ALL_LINGUAS="de"
+AM_GLIB_GNU_GETTEXT
+
+AM_GLIB_DEFINE_LOCALEDIR([LOCALEDIR])
+LOCALEDIR=$localedir
+AC_SUBST(LOCALEDIR)
+
+dnl ========================================================
AC_CONFIG_FILES([
Makefile
common/Makefile
@@ -53,6 +68,7 @@ AC_CONFIG_FILES([
actions/Makefile
actions/services/Makefile
src/Makefile
+ po/Makefile.in
])
AC_OUTPUT