summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-08-28 22:09:02 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-08-28 22:09:02 +0000
commit67b0d605554cc5d1836c6e112eb465d53e213330 (patch)
tree8c839fb24d71be729ed595af6374aa14b07d10b3 /configure.ac
parentf4b0f0626e54347eb9b56e19e69b9e8a451f0721 (diff)
* initial import
git-svn-id: file:///home/lennart/svn/public/service-discovery-applet/trunk@3 3be567f1-68ff-0310-b24a-ad7cc433fd2f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8ca6659
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,28 @@
+AC_PREREQ(2.57)
+AC_INIT([service-discovery-applet], [0.1], [sebastien (dot) estienne (at) gmail (dot) com])
+AC_CONFIG_SRCDIR([src/service-discovery-applet.in])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
+
+AM_MAINTAINER_MODE
+
+AM_PATH_PYTHON([2.4])
+AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(Could not find Python module pygtk)])
+AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(Could not find Python module dbus)])
+AM_CHECK_PYMOD(avahi,,,[AC_MSG_ERROR(Could not find Python module avahi)])
+
+SCRIPTSDIR="${datadir}/${PACKAGE}/scripts/"
+AC_SUBST(SCRIPTSDIR)
+ICONSDIR="${datadir}/${PACKAGE}/icons/"
+AC_SUBST(ICONSDIR)
+
+
+AC_CONFIG_FILES([
+ Makefile
+ common/Makefile
+ src/Makefile
+ icons/Makefile
+ scripts/Makefile
+ servers/Makefile
+])
+AC_OUTPUT