summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-09-17 13:40:38 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-09-17 13:40:38 +0000
commit7b771b3f042669e5d763864dd69560c4e2a5bb8d (patch)
treead437ce2f8d59b478c5f73409158d71ac49098ae /configure.ac
parent4da077afd60d5591b24a32b1082139516fd9f2c2 (diff)
* updated docs
* added a schema git-svn-id: file:///home/lennart/svn/public/service-discovery-applet/trunk@13 3be567f1-68ff-0310-b24a-ad7cc433fd2f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 37 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5f293d7..7adf226 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,36 +1,66 @@
-AC_PREREQ(2.57)
-AC_INIT([service-discovery-applet], [0.1], [sebastien (dot) estienne (at) gmail (dot) com])
+AC_PREREQ(2.59)
+AC_INIT([service-discovery-applet],[0.1],[sebastien (dot) estienne (at) gmail (dot) com])
AC_CONFIG_SRCDIR([src/service-discovery-applet.in])
-AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
AC_SUBST(VERSION)
AM_MAINTAINER_MODE
+dnl ========================================================
+dnl Check for python and some modules
+dnl ========================================================
AM_PATH_PYTHON([2.4])
AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(Could not find Python module pygtk)])
AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(Could not find Python module dbus)])
AM_CHECK_PYMOD(avahi,,,[AC_MSG_ERROR(Could not find Python module avahi)])
-AM_CHECK_PYMOD(gnomeapplet,,,[AC_MSG_ERROR(Could not find Python module gnomeapplet)])
+# disable because it needs a DISPLAY
+# AM_CHECK_PYMOD(gnomeapplet,,,[AC_MSG_ERROR(Could not find Python module gnomeapplet)])
+dnl ========================================================
+dnl Directory where services' scripts will be installed
+dnl ========================================================
SCRIPTSDIR="${datadir}/${PACKAGE}/scripts/"
AC_SUBST(SCRIPTSDIR)
+dnl ========================================================
+dnl Directory where services' icons will be installed
+dnl ========================================================
ICONSDIR="${datadir}/${PACKAGE}/icons/"
AC_SUBST(ICONSDIR)
+dnl ========================================================
+dnl Directory where glade interfaces will be installed
+dnl ========================================================
INTERFACESDIR="${datadir}/${PACKAGE}/interfaces/"
AC_SUBST(INTERFACESDIR)
+dnl ========================================================
+dnl This is to check correct gconf installation
+dnl ========================================================
+AM_GCONF_SOURCE_2
+
+dnl ========================================================
AC_CONFIG_FILES([
Makefile
common/Makefile
- src/Makefile
- scripts/Makefile
- servers/Makefile
icons/Makefile
icons/24x24/Makefile
icons/48x48/Makefile
+ schemas/Makefile
+ scripts/Makefile
+ servers/Makefile
+ src/Makefile
])
AC_OUTPUT
+
+dnl ========================================================
+dnl Summary
+dnl ========================================================
+echo "
+ ---{ $PACKAGE_NAME $VERSION }---
+
+ prefix: ${prefix}
+ sysconfdir: ${sysconfdir}
+ gconf config source: ${GCONF_SCHEMA_CONFIG_SOURCE}
+"