summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2006-08-06 23:52:31 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2006-08-06 23:52:31 +0000
commit27c6fade238336c61a5a01d22fe767bf664ca010 (patch)
treeab199c4381c7753a23c89289a698f15351764e96 /plugins/Makefile.am
parentd9313c80245a75e3b023a729eacec454e580b7a8 (diff)
display error messages when something goes wrong in plugins
git-svn-id: file:///home/lennart/svn/public/service-discovery-applet/trunk@115 3be567f1-68ff-0310-b24a-ad7cc433fd2f
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index d0b4e7b..893cc07 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,10 +1,37 @@
pluginsdir = $(PLUGINSDIR)
+plugins = \
+ gconfterminal.py.in \
+ nautilus.py.in \
+ xvncviewer.py.in \
+ ekiga.py.in
+
plugins_DATA = \
gconfterminal.py \
nautilus.py \
xvncviewer.py \
ekiga.py
+gconfterminal.py: gconfterminal.py.in
+ sed \
+ -e 's,@toolsdir\@,$(TOOLSDIR),g' \
+ $< > $@
+
+nautilus.py: nautilus.py.in
+ sed \
+ -e 's,@toolsdir\@,$(TOOLSDIR),g' \
+ $< > $@
+
+xvncviewer.py: xvncviewer.py.in
+ sed \
+ -e 's,@toolsdir\@,$(TOOLSDIR),g' \
+ $< > $@
+
+ekiga.py: ekiga.py.in
+ sed \
+ -e 's,@toolsdir\@,$(TOOLSDIR),g' \
+ $< > $@
+
+EXTRA_DIST = $(plugins)
-EXTRA_DIST = $(plugins_DATA)
+CLEANFILES = $(plugins_DATA)