summaryrefslogtreecommitdiffstats
path: root/src/modules/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/Makefile.am')
-rw-r--r--src/modules/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
new file mode 100644
index 0000000..d0c50d6
--- /dev/null
+++ b/src/modules/Makefile.am
@@ -0,0 +1,24 @@
+sdadir = $(pythondir)/sdapplet
+
+pythonscripts = \
+ pluginloader.py
+
+EXTRA_DIST = \
+ __init__.py \
+ pluginloader.py.in \
+ pluginutils.py
+
+sda_PYTHON = $(pythonscripts) pluginutils.py __init__.py
+
+pluginloader.py: pluginloader.py.in
+ sed \
+ -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@version\@,$(VERSION),g' \
+ -e 's,@iconsdir\@,$(ICONSDIR),g' \
+ -e 's,@actionsdir\@,$(ACTIONSDIR),g' \
+ -e 's,@GETTEXT_PACKAGE\@,$(GETTEXT_PACKAGE),g' \
+ -e 's,@LOCALEDIR\@,$(LOCALEDIR),g' \
+ $< > $@
+ chmod +x $@
+
+CLEANFILES = $(pythonscripts) *.pyc *.pyo