summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-07-19 16:28:19 +0000
committerLennart Poettering <lennart@poettering.net>2004-07-19 16:28:19 +0000
commitc9c32fafa054ac5817262eb2a17cab3d6c64973a (patch)
tree585ba0acdd82f21275521a42dbb1c4eb8a2de023 /configure.ac
parenta952692561d8b1c59d4a384812b52d7225953bb3 (diff)
add support for xattr omit
git-svn-id: file:///home/lennart/svn/public/syrep/trunk@59 07ea20a6-d2c5-0310-9e02-9ef735347d72
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d389f31..cb69d1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,9 @@ AC_CHECK_HEADER([sys/sendfile.h], sendfile=yes, sendfile=no)
if test "x$sendfile" = xyes ; then
AC_CHECK_LIB([c], [sendfile], sendfile=yes, sendfile=no)
+fi
+
+if test "x$sendfile" = xyes ; then
AC_DEFINE([USE_SENDFILE], [1], [Use sendfile()])
fi
@@ -79,6 +82,17 @@ else
AC_DEFINE([ARCH_IS_BIG_ENDIAN], [0], [Big Endian machine])
fi
+# Check for XATTR
+AC_CHECK_HEADER([attr/xattr.h], xattr=yes, xattr=no)
+
+if test "x$xattr" = xyes ; then
+ AC_CHECK_LIB([attr], [getxattr], xattr=yes, xattr=no)
+fi
+
+if test "x$xattr" = xyes ; then
+ AC_DEFINE([USE_XATTR], [1], [Use extended attributes])
+fi
+
# 64 Bit LFS support
AC_SYS_LARGEFILE