summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 88d14e4..203b481 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
AC_PREREQ(2.57)
-AC_INIT([syrep], [0.3], [mzflerc (at) 0pointer (dot) de])
+AC_INIT([syrep], [0.4], [mzflerc (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([src/syrep.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
@@ -49,6 +49,19 @@ AC_CHECK_HEADER([zlib.h],, [AC_MSG_ERROR([*** Sorry, you have to install the zli
AC_CHECK_HEADER([db.h],, [AC_MSG_ERROR([*** Sorry, you have to install the Berkeley Database Library (libdb) 4.1 or newer ***])])
LIBS="$LIBS -ldb"
+# Checking libdb version number
+AC_MSG_CHECKING([for Berkeley libdb 4.1])
+AC_LANG_PUSH(C)
+AC_PREPROC_IFELSE([AC_LANG_SOURCE([[
+#include <db.h>
+#if (DB_VERSION_MAJOR != 4) || (DB_VERSION_MINOR != 1)
+#error "foo"
+#endif
+]])],
+[AC_MSG_RESULT([yes])],
+[AC_MSG_FAILURE([Berkeley libdb 4.1 required])])
+AC_LANG_POP(C)
+
# Check for Linux sendfile()
AC_CHECK_HEADER([sys/sendfile.h], sendfile=yes, sendfile=no)
@@ -86,6 +99,7 @@ AC_FUNC_MALLOC
AC_FUNC_MEMCMP
AC_FUNC_MMAP
AC_FUNC_STAT
+AC_FUNC_REALLOC
AC_CHECK_FUNCS([atexit ftruncate getcwd gethostname memset mkdir munmap rmdir setenv strchr strdup strerror strrchr strtol])
# LYNX documentation generation