summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8f11994..11e59c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
AC_PREREQ(2.59)
-AC_INIT([syrep],[0.6],[mzflerc (at) 0pointer (dot) de])
+AC_INIT([syrep],[0.7],[mzflerc (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([src/syrep.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
@@ -47,6 +47,7 @@ AC_CHECK_HEADER([zlib.h],, [AC_MSG_ERROR([*** Sorry, you have to install the zli
# Check for Berkeley DB (needs to be improved)
AC_CHECK_HEADER([db.h],, [AC_MSG_ERROR([*** Sorry, you have to install the Berkeley Database Library (libdb) 4.2 or newer ***])])
+AC_CHECK_LIB([db], [db_create_4002],, [AC_MSG_ERROR([*** Sorry, you have to install the Berkeley Database Library (libdb) 4.2 or newer ***])])
LIBS="$LIBS -ldb"
# Checking libdb version number
@@ -109,13 +110,16 @@ AC_C_VOLATILE
# Checks for library functions.
AC_FUNC_CLOSEDIR_VOID
-AC_FUNC_MALLOC
-AC_FUNC_MEMCMP
+#AC_FUNC_MALLOC
+#AC_FUNC_MEMCMP
AC_FUNC_MMAP
-AC_FUNC_STAT
-AC_FUNC_REALLOC
+#AC_FUNC_STAT
+#AC_FUNC_REALLOC
AC_CHECK_FUNCS([atexit ftruncate getcwd gethostname memset mkdir munmap rmdir setenv strchr strdup strerror strrchr strtol])
+adl_FUNC_GETOPT_LONG
+lp_FUNC_MKDTEMP
+
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
AS_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),