summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 203b481..fe9941d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,8 +19,8 @@
# along with syrep; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-AC_PREREQ(2.57)
-AC_INIT([syrep], [0.4], [mzflerc (at) 0pointer (dot) de])
+AC_PREREQ(2.59)
+AC_INIT([syrep],[0.4],[mzflerc (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([src/syrep.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
@@ -50,11 +50,11 @@ AC_CHECK_HEADER([db.h],, [AC_MSG_ERROR([*** Sorry, you have to install the Berke
LIBS="$LIBS -ldb"
# Checking libdb version number
-AC_MSG_CHECKING([for Berkeley libdb 4.1])
+AC_MSG_CHECKING([for Berkeley libdb 4.2])
AC_LANG_PUSH(C)
AC_PREPROC_IFELSE([AC_LANG_SOURCE([[
#include <db.h>
-#if (DB_VERSION_MAJOR != 4) || (DB_VERSION_MINOR != 1)
+#if (DB_VERSION_MAJOR != 4) || (DB_VERSION_MINOR != 2)
#error "foo"
#endif
]])],
@@ -104,7 +104,7 @@ AC_CHECK_FUNCS([atexit ftruncate getcwd gethostname memset mkdir munmap rmdir se
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
- AC_HELP_STRING([--disable-lynx], [Turn off lynx usage for documentation generation]),
+ AS_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),
[case "${enableval}" in
yes) lynx=yes ;;
no) lynx=no ;;
@@ -123,7 +123,7 @@ AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
# XMLTOMAN manpage generation
AC_ARG_ENABLE(xmltoman,
- AC_HELP_STRING([--disable-xmltoman], [Disable rebuilding of man pages with xmltoman]),
+ AS_HELP_STRING(--disable-xmltoman,Disable rebuilding of man pages with xmltoman),
[case "${enableval}" in
yes) xmltoman=yes ;;
no) xmltoman=no ;;
@@ -143,7 +143,7 @@ AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
# gengetopt command line parser generation
AC_ARG_ENABLE(gengetopt,
- AC_HELP_STRING([--disable-gengetopt], [Disable rebuilding of command line parser with gengetopt]),
+ AS_HELP_STRING(--disable-gengetopt,Disable rebuilding of command line parser with gengetopt),
[case "${enableval}" in
yes) gengetopt=yes ;;
no) gengetopt=no ;;
@@ -163,7 +163,7 @@ AM_CONDITIONAL([USE_GENGETOPT], [test "x$gengetopt" = xyes])
# subversion release number generation
AC_ARG_ENABLE(subversion,
- AC_HELP_STRING([--disable-subversion], [Disable rebuilding of svn-release.h]),
+ AS_HELP_STRING(--disable-subversion,Disable rebuilding of svn-release.h),
[case "${enableval}" in
yes) subversion=yes ;;
no) subversion=no ;;