summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d389f31..cb69d1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,9 @@ AC_CHECK_HEADER([sys/sendfile.h], sendfile=yes, sendfile=no)
if test "x$sendfile" = xyes ; then
AC_CHECK_LIB([c], [sendfile], sendfile=yes, sendfile=no)
+fi
+
+if test "x$sendfile" = xyes ; then
AC_DEFINE([USE_SENDFILE], [1], [Use sendfile()])
fi
@@ -79,6 +82,17 @@ else
AC_DEFINE([ARCH_IS_BIG_ENDIAN], [0], [Big Endian machine])
fi
+# Check for XATTR
+AC_CHECK_HEADER([attr/xattr.h], xattr=yes, xattr=no)
+
+if test "x$xattr" = xyes ; then
+ AC_CHECK_LIB([attr], [getxattr], xattr=yes, xattr=no)
+fi
+
+if test "x$xattr" = xyes ; then
+ AC_DEFINE([USE_XATTR], [1], [Use extended attributes])
+fi
+
# 64 Bit LFS support
AC_SYS_LARGEFILE