summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am84
1 files changed, 84 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..3386f58
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,84 @@
+# $Id: Makefile.am 7 2003-08-04 23:05:55Z lennart $
+
+# This file is part of syrep.
+#
+# syrep is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# syrep is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with syrep; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+
+bin_PROGRAMS = syrep
+
+syrep_SOURCES = cache.c cache.h \
+ update.c update.h \
+ util.c util.h \
+ syrep.c syrep.h \
+ md5.c md5.h \
+ md5util.c md5util.h \
+ context.c context.h \
+ package.c package.h \
+ dbutil.c dbutil.h \
+ info.c info.h \
+ history.c history.h \
+ dump.c dump.h \
+ list.c list.h \
+ diff.c diff.h \
+ merge.c merge.h \
+ extract.c extract.h \
+ makepatch.c makepatch.h \
+ cleanup.c cleanup.h \
+ cmdline.c cmdline.h \
+ svn-revision.h \
+ dbstruct.h
+
+EXTRA_DIST = syrep.ggo
+MAINTAINERCLEANFILES =
+BUILT_SOURCES =
+
+if USE_GENGETOPT
+MAINTAINERCLEANFILES += cmdline.c cmdline.h
+BUILT_SOURCES += cmdline.c cmdline.h
+endif
+
+if USE_SUBVERSION
+MAINTAINERCLEANFILES += svn-revision.h
+BUILT_SOURCES += svn-revision.h
+endif
+
+syrep.$(OBJEXT): svn-revision.h cmdline.h
+update.$(OBJEXT): cmdline.h
+
+if USE_GENGETOPT
+
+cmdline.c cmdline.h: syrep.ggo Makefile
+ gengetopt --unamed-opts --no-handle-help --no-handle-version < $<
+
+endif
+
+if USE_SUBVERSION
+svn-revision.h: Makefile
+ if test -d "$(top_srcdir)/.svn" ; then \
+ if REV=`svn info "$(top_srcdir)" | grep ^Revision | cut -f2 -d" "` 2> /dev/null ; then \
+ echo -e "#ifndef foosvnrevisionhfoo\n#define foosvnrevisionhfoo\n#define SVN_REVISION \"$$REV\"\n#endif" > $@ ; \
+ fi \
+ fi
+
+svnkeywords:
+ rm -f svn-revision.h cmdline.[ch]
+ svn propset svn:keywords Id *.c *.h Makefile.am
+
+.PHONY: svnkeywords
+
+endif
+
+